GNS3 與 putty

 

GNS3 的 putty,預設是內建的

image

預設的設定是:

image

image

serial 的參數【SuperPutty.exe -serial “%s -wt \"%d\""】

telnet 的參數【putty.exe -telnet %h %p -wt “%d" -gns3 5 -skin 4】

預設的字體,font size 只有 10,而且沒有紀錄執行的指令,以及輸出的結果!這有點麻煩,這裡要將 GNS3,改成平常使用的 putty,要放大 Font size,也要記錄指令及輸出。

在 GNS3 的 putty,點選 putty icon 左鍵

image

或是在 title 的地方,點選滑鼠右鍵

image

選【Change Settings…】

image

加大 Font size

image

image

開啟 LOG

image

要將全部 console 的 LOG,通通寫到同一個檔案也是可以的,只是習慣將每個 router 的 LOG 分開,並不是強制要分。

記得要存檔

image

改好之後,Font size 立馬就放大了

image

也可以記錄指令及輸出

image

但是,關掉 putty 之後,下回再開啟 putty,又回到預設

image

只好再開一個新的 session

image

image

由於剛剛已經有寫紀錄到 LOG 檔【D:\tmp\putty_log-P1R1.txt】,如果要保留歷史紀錄,請選【N】,新的 LOG 將會 append 到檔尾,選擇【Y】的話,會變成是 overwrite,只記錄最新的這次,以前的紀錄就不見了!

image

這時候其實會開兩個【P1R1】這個 router 的 console,關掉剛剛那個沒有紀錄的 console 就可以了!

此時如果 GNS3 沒關,可以直接執行 putty【不用再去 GNS3,點選 router,在 double-click】,點選剛剛存檔的 session

image

要保留歷史紀錄的話,記得要選【N】

image

就可以直接開 P1R1 的 console

image

這樣使用 GNS3 + putty 練習,應該就會方便很多了吧!

張貼在 Cisco, 網路, Windows, Windows 10 | 發表留言

機場捷運圖

 

機場捷運就快要正式營運了,先來看看官方版的捷運圖吧!

原圖

張貼在 Bookmark, 生活, 旅遊 | 發表留言

清除 Router/Switch 的設定

開啟 GNS3

先簡單配置 Router / Switch

image

image

IOU1 是第一個 Router,簡單的設定 interface

>enable
#configure terminal
(config)#interface ethernet 0/0
(config-if)#ip address 192.168.0.1 255.255.255.0
(config-if)#no shutdown

image

IOU2 是 Switch,也是簡單的設定

#configure terminal
(config)#interface vlan 1
(config-if)#ip address 192.168.0.3 255.255.255.0
(config-if)#no shutdown

Router / Switch 互 ping,確定連線正常

image

清除 Router 的設定,建議拔掉全部的線

#write
#erase startup-config
#reload

image

image

檢查 Router 的設定,是否已經清除?

image

Switch 的動作是大同小異,多了一個清除 VLAN 設定的動作,其他都跟 Router 一樣

#write
#erase startup-config
#delete vlan.dat
#reload

image

檢查 Switch 的設定,是否已經清除?

image

張貼在 Cisco, 網路, GNS3 | 發表留言

putty紀錄輸出到文字檔

 

使用 putty 遠端登入 Linux 時,Linux 有提供 history 可以記錄執行過的指令,之前有寫過幾篇 history 的相關介紹:

history功能介紹

記錄 user 執行過的指令

history – 記錄全部的使用者執行過的指令

不過,必須要使用 Linux,並且,只有紀錄指令本身,並沒有記錄指令輸出的結果

putty 自己本身也可以記錄,是將 putty 畫面呈現的指令本身+輸出,全部紀錄

image

image

putty 的畫面看到的是:

image

指定的 LOG 檔看到的是:

image

提示符號有點亂碼,其他都正常,指令本身+輸出,通通都可以記錄下來!

LOG 會不會繼續累加呢?當第二次以後登入,由於 LOG檔【D:\tmp\putty_log.txt】已經存在,所以會出現一個訊息詢問

image

要記得,選【N】才是 append,以前的紀錄通通都會留著,選【Y】就變成 overwrite,以前的紀錄會被覆蓋掉!

張貼在 CentOS 6, CentOS 7, Cisco, 網路, Linux, RHEL 6, RHEL 7, Windows, Windows 10, Windows 2016 | 發表留言

Router/Switch 指令尋找關鍵字

 

Linux 的指令 – grep,可以用來尋找關鍵字,相當方便

image

在 Router/Switch 的 IOS,其實也可以找關鍵字

先看看原本的指令輸出

#show ip interface brief

image

輸出如果只有幾行,用眼睛找還不成問題,但是,如果遇到 show running-config 之類的指令呢?

簡單設定一下 telnet

image

先看看完整的指令,以 show running-config 為例:

image

像 show running-config 這個指令的輸出很多行,好幾頁,用肉眼找是比較辛苦的…

image

include 是找關鍵字【相當於 grep】,exclude 則相反【相當於 grep -v】

image

但是,只有一行,有時看不太清楚…

image

section include是找關鍵字,但是一整段顯示,不是只顯示一行

image

還支援 Regular Expression,太強了!

image

張貼在 Bookmark, CentOS 6, CentOS 7, Cisco, 網路, GNS3, Linux, RHEL 6, RHEL 7 | 發表留言

Router 設定 ssh 連線

 

參考比較:Router 設定 telnet 密碼

使用 GNS3模擬器,一樣要選 c7200

image

左邊 Router 的基本設定

#configure terminal
(config)#hostname R1
(config)#interface serial 1/0
(config-if)#ip address 192.168.0.1 255.255.255.252
(config-if)#clock rate 56000
(config-if)#no shutdown
(config-if)#exit
(config)#exit

image

設定 ssh 連線

#configure terminal
(config)#ip domain-name vclass.local【設定網域名稱】
(config)#crypto key generate rsa【產生金鑰】
(config)#username anderson privilege 15 password 3333【設定帳號、密碼,權限設為最高等級15】
(config)#line vty 0 4
(config-line)#login local【使用帳號、密碼作驗證】
(config-line)#exit
(config)#exit
#write

image

從右邊 Router 測試

#ssh -l anderson 192.168.0.1

image

要注意的是,telnet 的時候,也需要帳號/密碼

image

張貼在 Bookmark, Cisco, 網路, GNS3 | 發表留言

Router 設定 telnet 密碼

 

使用 GNS3模擬器,比較奇怪的是,要使用 c7200,如果選取 Cisco IOU L3 155-2T,就不 work 了,模擬器果然不是每個功能都可以正常運作…

image

左邊 Router 的基本設定

#config terminal
(config)#hostname R1
(config)#interface serial 1/0
(config-if)#ip address 10.0.0.1 255.255.255.252
(config-if)#clock rate 56000
(config-if)#no shutdown

image

右邊 Router 的基本設定

#config terminal
(config)#hostname R2
(config)#interface serial 1/0
(config-if)#ip address 10.0.0.2 255.255.255.252
(config-if)#clock rate 56000
(config-if)#no shutdown

image

#config terminal
(config)#line vty 0 4【開放五組telnet】
(config-line)#password 123【設定密碼為123】
(config-line)#login【套用】
(config-line)#exit
(config)#service password-encryption【加密密碼】
(config)#exit
#write【寫回NVRAM】

image

從右邊的 Router 測試

#ping 10.0.0.1
#telnet 10.0.0.1

image

可以看到提示符號的變化

提示符號是【>】,表示此時是在 User Mode,當輸入 enable 要進入 Privilege Mode 時,卻因為沒設定密碼而無法進入

image

先回到左手邊的 Router,設定 Privilege Mode 的密嗎

#config terminal
(config)#line console 0
(config-line)#password 456
(config-line)#login
(config-line)#exit
(config)#service password-encryption
(config)#exit
#write

image

 

回到右手邊的 Router,再 telnet 試試

image

這次 telnet 成功之後,可以 enable,進入 Privilege Mode

張貼在 Cisco, 網路, GNS3 | 1 則迴響